
Phần III: Sử dụng CNTT trong xây dựng kế hoạch dạy học 

1. Kỹ năng soạn thảo văn bản 

1.1. Tổng quan về soạn thảo văn bản 

- Soạn thảo văn bản cho phép người dùng làm những thao tác liên quan đến tạo lập văn bản như: gõ (nhập) 
văn bản, sửa đổi, trình bày, lưu trữ và in ấn văn bản. Việc soạn thảo văn bản có thể được thực hiện dưới 
nhiều hình thức khác nhau, nhưng theo nghĩa hẹp có thể hiểu soạn thảo văn bản được thực hiện bằng 
các phần mềm trên các thiết bị điện tử như máy vi tính, máy tính bảng, điện thoại… 

- Có nhiều phần mềm xử lí văn bản khác nhau như LibreOffice Writer, OpenOffice Writer, 
FocusWriter, Jarte, Microsoft Word… Trong đó Microsoft Word là công cụ soạn thảo văn bản thông 
dụng nhất hiện nay.  

1.2. Sử dụng Microsoft Word (Word) 

1.2.1. Khởi động Word 

Để khởi động Word, nhấn đúp vào biểu tượng Word trên màn hình Desktop. Hình bên cho biết biểu tượng 

Microsoft Word qua một số phiên bản  

1.2.2. Tạo một văn bản mới 

- Chọn File > New > Blank document 
- Cách 2: Nhấn tổ hợp phím Ctrl + N 

1.2.3. Mở một văn bản 

- Cách 1: Chọn File > Open > chọn file văn bản cần mở 
- Cách 2: Nhấn tổ hợp phím Ctrl + O > chọn file văn bản cần mở  
- Cách 3: Nhấn đúp vào file văn bản cần mở 

1.2.3. Lưu một văn bản 

- Cách 1: Chọn File > Save - Cách 2: Nhấn tổ hợp phím Ctrl + S 
• Nếu văn bản này trước đó chưa được lưu lại, Word  sẽ yêu cầu đặt tên file và chọn vị trí lưu trữ. Để lưu 

văn bản thành một file khác, chọn File > Save as hoặc nhấn phím F12.  
• Trong khi lưu văn bản, có thể tùy chọn định dạng của văn bản theo các phiên bản khác nhau của Word. 

Nếu người dùng không lựa chọn, văn bản sẽ được lưu ở định dạng mặc định tương ứng với phiên bản 
Word đang sử dụng.  

1.2.4. Sao lưu tự động 

Để đề phòng các sự cố như mất điện, treo máy…, người dùng nên bật tính năng sao lưu tự động theo 

chu kì: Chọn File > Options > Save và tùy chọn chế độ sao lưu tự động theo ý thích, ví dụ như sau: 



 
1.2.5. Các lệnh thường dùng 

Lệnh Biểu tượng Phím tắt Ý nghĩa 

Cut 
 

Ctrl + X Chuyển đoạn văn bản đã chọn vào bộ nhớ Clipboard 

Copy  Ctrl + C Chép đoạn văn bản đã chọn vào bộ nhớ Clipboard 

Paste  Ctrl + V Dán đoạn văn bản trong bộ nhớ Clipboard vào vị trí 
con trỏ soạn thảo 

Select All  Ctrl + A Chọn toàn bộ văn bản  

Undo Typing  Ctrl + Z Hủy bỏ thao tác vừa thực hiện (hoàn tác) 

Repeat Typing  Ctrl + Y Khôi phục lại thao tác vừa bị hoàn tác hoặc lặp lại thao 
tác vừa thực hiện 

1.3. Định dạng văn bản 

1.3.1. Định dạng kí tự (Font) 

Để định dạng kí tự, ta sử dụng nhóm công 
cụ Font trên tab Home của thanh Ribbon 

Trong đó:  

- Font chữ: Font chữ thường được sử dụng 
trong các văn bản là Times New Roman. 
Ngoài ra một số font chữ khác cũng khá phổ biến như: Calibri, Arial, Cambria… Để sử dụng thêm các 
font chữ chưa có sẵn, người dùng cần tải font chữ đó về và cài đặt.  

- In đậm, in nghiêng, gạch chân:  

Lệnh Biểu tượng Phím tắt Ý nghĩa 

Bold 
 

Ctrl + B In đậm đoạn văn bản đã chọn 

Italic  Ctrl + I In nghiêng đoạn văn bản đã chọn 

Underline  Ctrl + U Gạch chân đoạn văn bản đã chọn 

Subscript  Ctrl + = Đưa kí tự đã chọn thành chỉ số dưới 

Superscript  
Ctrl + Shift 
+ = Đưa kí tự đã chọn thành chỉ số trên 



- Màu chữ, cỡ chữ, đánh dấu (Highlight): 

 

- Đánh chỉ số trên, chỉ số dưới:  

Lệnh Biểu tượng Phím tắt Ý nghĩa 

Subscript  Ctrl + = Đưa kí tự đã chọn thành chỉ số dưới 

Superscript  Ctrl + Shift + = Đưa kí tự đã chọn thành chỉ số trên 

1.3.2. Định dạng đoạn (Paragraph) 

Để định dạng đoạn, ta sử dụng nhóm công cụ Paragraph trên tab Home của thanh Ribbon 

 

Biểu 
tượng Lệnh (Phím tắt) Ý nghĩa 

(1) Bullets Tạo một danh sách bullets (đánh dấu các ý bằng các kí tự) 

(2) Numbering Tạo một danh sách có đánh số 

(3) Multilevel list Tạo một danh sách với tổ chức nhiều cấp độ hoặc một đề cương 

(4) Align Left (Ctrl + L) Căn lề trái  

(5) Center (Ctrl + E) Căn giữa 

(6) Align Right (Ctrl + R) Căn lề phải 

(7) Justify (Ctrl + J) Căn đều hai bên 

(8) Decrease Indent Di chuyển đoạn lại gần lề 

(9) Increase Indent Di chuyển đoạn ra xa lề 

(10) Sort Sắp xếp theo bảng chữ cái hoặc số thứ tự 

(11) Show/Hide (Ctrl + *) Hiển thị/ẩn các đánh dấu đoạn hoặc các kí tự ẩn khác 

(12) Borders Tạo đường viền cho đoạn  



(13) Shading Tô màu nền cho đoạn 

(14) Line and Paragraph Spacing Điều chỉnh khoảng cách giữa các dòng, giữa các đoạn 

1.3.3. Sử dụng Styles (Kiểu dáng) 

a. Styles là gì? Tại sao nên sử dụng Styles? 

Style là tập hợp của các định dạng được áp dụng đối với một phần văn bản như cỡ chữ, font chữ, màu 
chữ, màu nền, khoảng cách giữa các dòng… Việc sử dụng Styles trong Word giúp người dùng: 

- Thống nhất định dạng cho các phần trong văn bản 
- Tiết kiệm thời gian trong quá trình định dạng 

văn bản.  

- Dễ dàng xem được cấu trúc tài liệu (View > 
Navigation Pane). 

- Hỗ trợ tạo mục lục tự động. 

Nhóm công cụ Styles trên tab Home của thanh Ribbon: 

 
b. Cách áp dụng Styles cho văn bản  

- Để áp dụng một Style nào đó cho phần văn bản cần định dạng, người dùng chỉ cần chọn phần văn bản 
đó rồi chọn Style phù hợp trong nhóm công cụ Style. 

- Để tổ chức văn bản thành một cấu trúc nhiều cấp độ từ lớn đến nhỏ, sử dụng các Style tương ứng từ 
Heading 1 đến Heading 2, Heading 3,…  

c. Thay đổi các định dạng có sẵn của Styles 

Word cũng cho phép người dùng thay đổi các định dạng sẵn có của Styles. Để thay đổi định dạng cho một 

Style, nhấn chuột phải vào Style đó và chọn Modify. Khi đó hộp thoại Modify Style xuất hiện và người 
dùng có thể tùy chỉnh định dạng của Style đó. 

d. Thêm hoặc xóa các Style  

- Để xóa một Style, nhấn chuột phải vào Style đó và chọn Remove from Style Gallery: 
- Để tạo một Style mới, có sự khác biệt nhỏ giữa các phiên bản Word: 

• Word 2013 trở về sau: nhấn chọn mũi tên More trong nhóm công cụ Styles > Create a Style. 
• Word 2007 và 2010: nhấn chọn mũi tên More trong nhóm công cụ Styles > Save Selection as a 

New Quick Style. 



e. Sao chép định dạng  

Để sao chép nhanh định dạng của một đoạn văn bản này sang một đoạn văn bản 
khác, trước hết các bạn chọn một đoạn văn bản hoặc đặt con trỏ soạn thảo vào 

giữa đoạn văn bản muốn sao chép định dạng, sau đó trong tab Home, nhấn chọn 

Format Painter với biểu tượng hình cây chổi quét sơn. Khi con trỏ chuột chuyển 

thành biểu tượng cây chổi quét sơn, đưa con trỏ chuột đặt vào đoạn văn bản muốn 
thay đổi định dạng.  

 

1.4. Chèn các đối tượng khác vào văn bản 

Một cách tổng quát, để chèn các đối tượng vào văn bản là nhấn chọn tab Insert trên thanh Ribbon. Tại 

đây, tùy vào phiên bản Word, người dùng sẽ quan sát được các loại đối tượng được chia thành từng ô. 

Phiên bản Word 2016 cho phép người dùng chèn các đối tượng: Pages, Tables, Illustrations, Add-ins, 
Media, Links, Comments, Header & Footer, Text, Symbols. Trong phạm vi tài liệu này, chúng tôi chỉ giới 

thiệu về một số đối tượng cơ bản thường dùng:  

1.4.1. Tables - Chèn bảng 

a. Tạo bảng 

Để chèn bảng vào văn bản, đặt con trỏ soạn thảo tại vị trí muốn chèn bảng. Trong tab Insert, nhấn chọn 
biểu biểu tượng Table, sau đó di chuyển con trỏ chuột để chọn số hàng và số cột của bảng. Hoặc bạn có 

thể nhấn chọn Insert Table… để nhập số hàng/số cột muốn tạo. 

b. Chỉnh sửa bảng 

Khi vừa chèn bảng xong, trên thanh Ribbon xuất hiện nhóm thẻ Table Tools với hai tab là Design và Layout, 
lúc này người dùng có thể nhập nội dung vào bảng và tiến hành chỉnh sửa bảng: 

- Thay đổi kích thước bảng: đưa con trỏ chuột đến góc phải phía bên dưới của bảng, nhấn giữ vào mũi 
tên hai chiều và kéo rộng hoặc thu hẹp kích thước của bảng theo ý muốn.  

- Căn chỉnh vị trí, hướng của đoạn văn bản trong các ô của bảng: chọn ô (hoặc nhiều ô) muốn căn chỉnh, 
nhấn chọn tab Layout trong Table Tools. Tại nhóm công cụ Alignment, người dùng có thể thể căn 
chỉnh vị trí hoặc đoạn văn bản trong ô; điều chỉnh lề của ô. 

- Thay đổi định dạng bảng: chọn bảng muốn thay đổi định dạng, nhấn chọn tab Design trong Table Tools. 
Tại đây, người dùng có thể chọn các định dạng bảng có sẵn trong Table Styles hoặc tự điều chỉnh 
Shading (màu nền), Border Styles (kiểu viền) cho bảng. 

- Gộp ô: chọn các ô cần gộp, sau đó nhấn chuột phải và chọn Merge Cells.  
- Tách ô: đặt con trỏ chuột vào ô cần tách, sau đó nhấn chuột phải và chọn Split Cells. Sau khi hộp thoại 

Split Cells xuất hiện, nhập số cột và số hàng muốn tách thành và chọn OK. 



1.4.2. Illustration - Chèn minh họa 

Để chèn minh họa vào văn bản, người dùng sử dụng 

nhóm công cụ Illustration trong tab Insert của thanh 

Ribbon: 

(1) Pictures – Chèn hình ảnh từ máy tính 

(2) Online Pictures – Tìm kiếm và chèn hình 
ảnh từ các nguồn trực tuyến 

(3) Shapes – Vẽ hình từ những hình mẫu đã có sẵn 

(4) SmartArt – Chèn hình đồ họa SmartArt (hình tượng hóa các dữ liệu) 

(5) Chart – Chèn một biểu đồ 

(6) Screenshot – Chụp ảnh màn hình của một cửa sổ đang mở và chèn vào văn bản 

1.4.3. Symbols – Chèn kí hiệu và công thức  

Để chèn các kí hiệu hoặc công thức vào văn bản, người dùng sử dụng nhóm công cụ Symbols trong tab 
Insert của thanh Ribbon như sau: 

- Chèn kí hiệu: Đặt con trỏ soạn thảo ở vị trí cần chèn, sau đó chọn Symbols > More Symbols. Khi hộp 
thoại Symbols xuất hiện, lụa chọn kí hiệu muốn chèn và nhấn chọn Insert. 

- Chèn công thức: Đặt con trỏ soạn thảo ở vị trí cần chèn, sau đó chọn Equation > Insert New Equation. 
Lúc này trên thanh Ribbon xuất hiện nhóm thẻ Equation > Design. Các cấu trúc toàn học cũng như các 
kí hiệu được hiển thị để người dùng có thể lựa chọn và nhập công thức: 

 

1.5.  Một số công cụ giúp tiết kiệm thời gian khi soạn thảo văn bản 

1.5.1. Sử dụng công cụ Tìm kiếm (Find) 

Công cụ này gúp người dùng dễ dàng tìm kiếm từ khóa bất kì trong toàn bộ văn bản, đếm được số lần từ 
khóa xuất hiện và di chuyển đến từng vị trí xuất hiện đó.  

- Cách 1: Chọn Home > Find (thuộc nhóm công cụ Editing) 

- Cách 2: Nhấn tổ hợp phím Ctrl + F 

1.5.2. Sử dụng công cụ Thay thế (Replace) 

Công cụ này giúp người dùng dễ dàng thay thế từ khóa bất kì bởi từ khóa khác.  



- Cách 1: Chọn Home > Replace  - Cách 2: Nhấn tổ hợp phím Ctrl + H 

 
1.5.3. Sử dụng chức năng gõ tắt trong AutoCorrect 

Với cách sử dụng AutoCorrect, người dùng có thể đơn giản hóa việc nhập các từ, cụm từ, thuật ngữ, công 
thức… dài, phức tạp bằng cách thiết lập gõ tắt chúng bởi các kí tự khác: File > Options > Proofing > 
AutoCorrect Options… Khi hộp thoại AutoCorrect xuất hiện, nhập các từ gõ tắt muốn thiết lập, sau đó 
nhấn chọn Add và OK. 

1.5.4. Sử dụng và bật/tắt đánh số tự động (AutoNumbering) 

Đánh số tự động là một tính năng khá tiện dụng 

trong Microsoft Word, tuy nhiên trong một số 

trường hợp nhất định lại gây phiền toái cho người 
dùng. Để cài đặt bật/tắt đánh số tự động, thực hiện 

như sau: File > Options > Proofing > AutoCorrect 

Options… 

Khi hộp thoại AutoCorrect xuất hiện, nhấn chọn tab 

AutoFormat As You Type, tại đây tích chọn/bỏ chọn 
ô Automatic numbered lists để bật hoặc tắt tính 
năng đánh số tự động, sau đó nhấn chọn OK.  

2. Kỹ năng thiết kế hình ảnh tư liệu 

Các học liệu dạng hình ảnh (kênh hình) thường dùng trong dạy học bao gồm: tranh ảnh, bản đồ, biểu 

đồ… 

2.1. Giới thiệu và phân biệt một số định dạng hình ảnh phổ biến 

Để nhận biết định dạng của một hình ảnh, cách đơn giản nhất là nhìn vào phần mở rộng (sau dấu chấm) 
của tên file. 

 

Các định dạng hình ảnh phổ biến hiện nay là JPG (hoặc JPEG), PNG và GIF. 



 *.JPG hoặc *.JPEG *.PNG *.GIF 

Ưu 
điểm 

- Là định dạng tiêu chuẩn cho 
hầu hết máy ảnh kĩ thuật số 

hiện nay 

- Có thể hiện thị vô số màu 

- Cho phép nén hình ảnh một 
cách linh hoạt, làm nhẹ dung 

lượng lưu trữ. 

- Có thể nén ảnh tối đa ngang với các 
định dạng khác nhưng không làm 

giảm chất lượng ảnh 

- Hỗ trợ nền trong suốt 

- Hỗ trợ lưu hình ảnh trong 
suốt và các hình ảnh động. 

- Nén nhiều hình ảnh mà 
không làm thay đổi chất 

lượng, dữ liệu sau khi nén 

không bị mất như *.JPG 

- Dung lượng nhỏ 

Nhược 
điểm 

- Chất lượng ảnh bị giảm khi 

nén, không thích hợp để chỉnh 
sửa ảnh 

- Không bảo tồn được phần 
trong suốt của ảnh 

- Dung lượng khá lớn 

- Khó hoặc không sử dụng được trên 

các trình duyệt web cũ 

 

- Chỉ hiển thị được tối đa 256 

màu cơ bản 

- Hiện nay đã khá lỗi thời  

Sử 

dụng 

Được sử dụng tốt nhất trong 
các ảnh mẫu, ảnh chụp, ảnh có 

màu sắc phức tạp hoặc tương 
phản. 

Phù hợp với các logo, ảnh trên 
website, ảnh đang chỉnh sửa hoặc các 

bức ảnh cần chi tiết mà không quan 
trọng đến dung lượng ảnh. 

Thường được dùng để tạo 
những icon nhỏ, ảnh động 

đơn giản hay các ảnh trong 
suốt thô. 

2.2. Chụp ảnh 

2.2.1. Chụp ảnh bằng điện thoại di động hoặc máy chụp hình 

Với sự phổ biến của các thiết bị như điện thoại thông minh hoặc máy chụp hình hiện nay, việc chụp ảnh 

ngày càng trở nên đơn giản. Tuy nhiên, về mặt kĩ thuật, người chụp ảnh cần chú ý: 

- Giữ mặt kính (máy chụp hình) hoặc camera (điện thoại) sạch và không bám bụi. 
- Tập trung vào đối tượng cần chụp ảnh. 
- Đo sáng và lấy nét vào đối tượng. Hiện nay hầu hết camera của các điện thoại thông minh đều có chức 

năng điều chỉnh độ sáng và lấy nét.  
- Sử dụng phông nền cho các hình ảnh cần quan sát chi tiết. 

2.2.2. Chụp ảnh màn hình máy tính 

Để chụp ảnh màn hình máy tính, có một số cách đơn giản sau: 

a. Chụp màn hình bằng bàn phím 

- Tùy thuộc vào máy tính, nhấn tổ hợp phím Windows + PrtSc hoặc Windows + Fn + PrtSc. Khi đó, 
ảnh chụp màn hình sẽ được tự động lưu vào thư mục Screenshots có sẵn trên máy tính ở vị trí sau: 
This PC (hoặc My Computer) > Pictures > Screenshots. 

- Sau khi chụp màn hình bằng cách này, bạn có thể dán ảnh vừa chụp vào văn bản, phần mềm chỉnh sửa, 
cửa sổ chat, khung soạn thảo… bất kì bằng cách sử dụng tổ hợp phím Ctrl + V.  



- Cách chụp này sẽ chụp lại toàn bộ màn hình, bao gồm cả Taskbar (thanh tác vụ). Để lấy một phần của 
hình chụp màn hình, bạn vẫn thực hiện chụp ảnh màn hình như trên, sau đó thực hiện như sau: 
• Tìm đến hình ảnh đã chụp và nhấn chuột phải, chọn Edit. 
• Khi hình ảnh được mở bằng ứng dụng Paint, nhấn chọn Select và kéo chuột để chọn phần phần 

hình ảnh muốn giữ lại. 
• Nhấn chọn Crop rồi lưu hình ảnh đã chỉnh sửa lại.  

b. Chụp màn hình bằng Snipping Tool 

Snipping Tool là công cụ được tích hợp sẵn trên mọi bản Windows. Khác với cách chụp bằng bàn phím, 

Snipping Tool cho phép người dùng chụp bất kì khu vực nào trên màn hình máy tính với khuôn khổ, kích 
thước nhất định. 

- Để mở Snipping Tool, đối với Windows 7, Windows 10, người dùng vào Start gõ “Snipping Tool” sẽ 
thấy công cụ này xuất hiện. Trên Windows 8 hoặc 8.1, di chuột vào góc trên bên phải màn hình, nhấp 
vào biểu tượng tìm kiếm và nhập “Snipping Tool” và nhấp vào 
Snipping Tool trong kết quả. Sau khi đã mở được công cụ này, để 
thuận lợi trong việc sử dụng thường xuyên, người dùng có thể nhấn 
chọn chuột phải vào biểu tượng của công cụ và chọn Pin to 
taskbar để ghim công cụ này trên thanh tác vụ. 

- Tại cửa sổ làm việc của Snipping Tool, nhấn chọn mũi tên bên 
phải chữ Mode, lựa chọn 1 trong 4 tùy chọn sau để giới hạn phạm vi 
chụp ảnh trên màn hình: 
• Free – form Snip: Chụp ảnh tự do, viền ảnh và đường do bạn 

khoanh trên màn hình 
• Rectangular Snip: Chụp ảnh với khung hình chữ nhật 
• Window Snip: Chụp ảnh một cửa sổ đang mở 
• Full-screen Snip: Chụp ảnh toàn màn hình 

c. Chụp màn hình trên máy tính Macbook (MacOS) 

- Chụp ảnh toàn màn hình: Nhấn tổ hợp phím Shift + Command (⌘) + 3. Ảnh chụp sẽ được lưu tự động 
trên màn hình chính.  

- Chụp một phần màn hình tùy chọn: Nhấn tổ hợp phím Shift + Command + 4, con trỏ chuột sẽ thay đổi 
thành hình chữ thập. Di chuyển chữ thập đến vùng bạn muốn bắt đầu chụp và kéo đến hết vùng cần 
chụp. Trong khi kéo, giữ phím Shift, Option hoặc Space để thay đổi cách di chuyển vùng chọn. Khi đã 
chọn xong, nhả chuột hoặc trackpad. Để hủy bỏ, nhấn phím Esc trước khi bạn nhả chuột. Ảnh chụp 
màn hình được lưu dưới dạng file *.PNG trên màn hình chính.  

2.3. Sử dụng các hình ảnh có sẵn từ Internet 

Để khai thác hiệu quả nguồn tài nguyên ảnh có sẵn từ Internet này, giáo viên cần trang bị cho mình các kỹ 

năng tìm kiếm và chọn lọc dữ liệu hình ảnh nhất định. Sau đây, chúng tôi giới thiệu một số kĩ năng tìm 

kiếm hình ảnh với công cụ tìm kiếm Google tại địa chỉ https://images.google.com/: 



2.3.1. Tìm kiếm hình ảnh bằng từ khóa 

- Từ khóa càng phổ biến hoặc càng sát với nội hàm của đối tượng sẽ cho kết quả nhiều và chính xác hơn.   
- Thông thường, các tìm kiếm với từ khóa bằng tiếng Anh sẽ cho kết quả nhiều và phong phú hơn.  
- Có thể diễn đạt từ khóa bằng nhiều cách khác nhau nếu chưa tìm được kết quả mong muốn.  

2.3.2. Tìm kiếm nâng cao 

Để tìm kiếm một cách cụ thể hơn, người dúng có thể sử dụng chức năng tìm kiếm với các tùy chọn đi kèm 

bằng cách nhấn chọn Tools (hoặc Công cụ). Lúc này, hiện ra các tùy chọn với hình ảnh như hình: 

 

- Kích thước (Size) – độ lớn, nhỏ của ảnh 
- Màu (Color) – màu sắc chủ đạo của ảnh 

- Loại (Type) – loại ảnh muốn tìm kiếm 
- Time (Thời gian) – thời gian ảnh được đăng  

2.3.3. Tìm kiếm bằng hình ảnh  

Ngoài cách nhập từ khóa, Google cũng hỗ trợ người dùng tìm kiếm bằng hình ảnh.  

❶ Tại ô tìm kiếm của Google Hình ảnh (https://images.google.com/), nhấn chọn biểu tượng máy ảnh 

như hình dưới đây: 

 
Lúc này ô Tìm kiếm bằng hình ảnh (Search by image) xuất hiện: 



 
❷ Tại đây, bạn có thể lựa chọn các cách sau để đưa hình ảnh vào tìm kiếm:  

- Tìm kiếm bằng hình ảnh có sẵn trên máy tính: 
• Nhấn chọn Tải ảnh lên và tìm đến hình ảnh trên máy tính, nhấn chọn Mở (Open) hoặc Chọn 

(Choose).Hoặc giữ chuột vào hình ảnh rồi kéo thả vào hộp tìm kiếm.  
• Nhấn chọn Tìm kiếm bằng hình ảnh hoặc nhấn phím Enter. 

- Tìm kiếm bằng hình ảnh trên Internet: 
• Nhấp chuột phải vào hình ảnh bất kì trên Internet và chọn Sao chép địa chỉ hình ảnh (Copy image 

address). Dán địa chỉ vừa copy vào ô tìm kiếm và nhấn chọn Tìm kiếm bằng hình ảnh hoặc nhấn 
phím Enter. 

2.4. Thiết kế và chỉnh sửa hình ảnh 

Hiện nay, có rất nhiều phần mềm hoặc ứng dụng giúp thiết kế và chỉnh sửa hình ảnh với mức độ từ đơn 
giản đến phức tạp khác nhau. Trong phạm vi tài liệu này, với mục đích sử dụng trong xây dựng nội dung 

trong dạy học, chúng tôi chỉ giới thiệu các công cụ đơn giản, dễ sử dụng đối với giáo viên: 

2.4.1. Paint 

Paint là một ứng dụng sẵn có trên mọi phiên bản Windows với các công cụ vẽ và chỉnh sửa ảnh cơ bản.  

- Chỉnh sửa hình ảnh với Paint: nhấn chuột phải vào hình ảnh đó và chọn Edit. 
- Crop (cắt ảnh): trong tab Home, nhấn chọn Select và kéo chuột để chọn phần phần hình ảnh muốn giữ 

lại, sau đó nhấn chọn Crop. 
- Resize & Skew (thay đổi kích thước và làm nghiêng): Trên tab Home, nhấn chọn Resize. Lúc này 

hiện ra hộp thoại Resize and Skew với nhiều tùy chọn về thay đổi kích thước hoặc làm nghiêng ảnh.  
- Rotate & Flip (quay và lật ảnh): Trong tab Home, nhấn 

chọn vào Rotate, xuất hiện các tùy chọn xoay và lật ảnh theo 
các góc và các hướng khác nhau. Nhấn chọn kiểu xoay/lật 
muốn thực hiện. 

- Chèn text (chữ) vào ảnh: Để chèn text vào hình ảnh, trong 
tab Home, chọn biểu tượng chữ A, sau đó đưa con trỏ chuột 
xuống vị trí muốn chèn và nhập text. Bạn cũng có thể thay đổi 
tùy chọn font của text hoặc thay đổi nền của ô text.  

- Chèn ảnh vào ảnh: Trong tab Home, nhấn chọn Paste > 
Paste from và tìm đến hình ảnh muốn dán, chọn và nhấn Open (Mở).  



- Chèn một phần của hình ảnh khác vào hình ảnh đang sửa: Mở hình ảnh muốn sao chép trong Paint, 
Select và kéo chuột để chọn vùng hình ảnh muốn sao chép, sau đó nhấn chuột phải chọn Copy (Ctrl + 
C). Mở đến hình ảnh muốn dán và chọn Paste (Ctrl + V). Vẽ thêm hình vào ảnh: Paint cho phép người 
dùng vẽ thêm một số hình dạng cơ bản vào hình ảnh.  

- Để vẽ thêm một hình vào ảnh, nhấn chọn hình dạng tương ứng trong Shapes, sau đó đặt con trỏ chuột 
vào ảnh và kéo, di chuyển để điều chỉnh kích thước hình muốn chèn. Bạn cũng có thể chọn màu, điều 
chỉnh độ lớn của nét… cho hình vừa vẽ. 

- Tô màu với công cụ Fill with color: Để tô màu 
cho một vùng bất kì trong ảnh, nhấn chọn biểu 
tượng Fill with color (thùng sơn) như trong hình, 
sau đó nhấn chọn màu mà bạn muốn tô rồi đưa con 
trỏ chuột đến một điểm trong vùng mà bạn muốn 
tô màu. 

Tuy nhiên, công cụ này chỉ sử dụng được với 

những hình ảnh hoạt họa, có độ đồng đều màu 

tương đối; không phù hợp với những hình chụp 
hoặc hình chất lượng thấp. 

Lưu ý: Một nhược điểm của Paint là không cho phép lưu ảnh với nền trong suốt, tất cả các vùng trong suốt 
trong ảnh đều sẽ trở thành màu trắng trong ảnh được lưu.  

2.4.2. PowerPoint 

Xuất phát là một phần mềm trình chiếu, tuy nhiên cho đến nay PowerPoint đã thực sự trở thành một 
công cụ tương đối mạnh trong thiết kế và chỉnh sửa đồ họa. Trong phạm vi tài liệu này, chúng tôi chỉ giới 

thiệu một cách sơ lược về các công cụ vẽ và chỉnh sửa hình ảnh của PowerPoint: 

a. Vẽ hình 

Bằng việc cung cấp các đa dạng các 
công cụ như chèn các loại đối tượng, 
tùy chỉnh và hiệu ứng với từng đối 
tượng, PowerPoint cho phép người 
dùng tự do thiết kế các hình vẽ từ 
mức độ đơn giản đến phức tạp. Ví 
dụ chỉ từ các hình khối cơ bản trong 
Insert > Shapes của PowerPoint, ta 
có thể vẽ hình ngôi nhà như hình 
bên.  

 

Trong khi hoặc sau khi đã hoàn thành, để các đối tượng giữ nguyên tỉ lệ kích thước, vị trí tương đối với 
nhau trong khi di chuyển hoặc điều chỉnh kích thước hình, người dùng nên nhóm chúng thành một nhóm 



bằng cách chọn các đối tượng và nhấn chuột phải chọn Group. Để lưu hình vừa vẽ thành file hình ảnh, 

nhấn chọn chuột phải vào hình hoặc group đó và chọn Save as picture: 

 
b. Chỉnh sửa ảnh có sẵn 

Trong trường hợp chỉnh sửa một ảnh có sẵn, ngay sau khi chèn ảnh vào PowerPoint, người dùng có thể 

thấy tab Format (Picture Tools) xuất hiện. Tại đây có đầy đủ các công cụ chỉnh sửa và thêm hiệu ứng cho 

hình ảnh. Các công cụ này có thể hơi khác nhau đối với các phiên bản Office, tuy nhiên thông thường đều 
có các chức năng sau:  

 
❶ Remove background (xóa bỏ nền của hình ảnh)  

Tính năng này chỉ có ở các phiên bản Office 2010 trở lên và thường được sử dụng để tạo các hình ảnh với 

nền trong suốt. Cách sử dụng tính năng này như sau:  

• Trước hết, chèn hình ảnh muốn xóa nền vào PowerPoint. Sau khi chèn xong, trên thanh Ribbon 
xuất hiện tab Format (Picture Tools). Nhấn chọn vào hình ảnh, sau đó chọn Remove Background:  

 
• Lúc này, hình ảnh đã chọn được chia thành 2 vùng. Vùng màu tím là vùng nền sẽ được xóa bỏ, vùng 

giữ nguyên màu gốc là vùng được giữ lại. Để điều chỉnh phạm vi của 2 vùng này, người dùng sử 
dụng các nút đánh dấu vùng cần xóa bỏ hoặc đánh dấu vùng cần giữ lại như trong hình dưới đây: 



 

• Sau khi lưu thay đổi, ta thu được hình 
ảnh với nền đã được xóa bỏ như hình 
dưới đây. Khi chọn lưu thành tệp hình 
ảnh (Save as picture), hình ảnh được lưu 
dưới định dạng *.png sẽ có phần nền 
trong suốt.  

❷ Adjust:  
• Corrections: cải thiện độ sáng, độ tương phản 

và độ sắc nét của hình ảnh 
• Color: điều chỉnh màu sắc của hình ảnh để cải 

thiện chất lượng hoặc để phù hợp với nội dung 
văn bản 

• Artistic Effects: thêm hiệu ứng nghệ thuật cho hình ảnh để làm cho nó trông giống như phác họa 
hoặc tranh vẽ 

• Compress Pictures: nén hình ảnh nhằm giảm dung lượng file  
• Change Picture: thay đổi thành hình ảnh khác nhưng giữ nguyên định dạng và kích thước của 

hình ảnh hiện tại 
• Reset Picture: hủy bỏ tất cả các thay đổi về định dạng của hình ảnh  

❸ Picture Styles: 

 
• Picture Border: chọn lựa màu sắc, độ dày và kiểu đường cho đường viền của hình ảnh 
• Picture Effects: áp dụng một hiệu ứng cho hình ảnh như đổ bóng, phát sáng, phản chiếu, xoay 3D 
• Picture Layout: chuyển đổi hình ảnh thành dạng đồ họa Smartart  

❹ Arrange: 
• Bring Forward: đưa hình ảnh được chọn lên phía trước  
• Send Backward: đưa hình ảnh được ra phía sau  
• Selection Pane: hiển thị danh sách các đối tượng  
• Align: Thay đổi vị trí của hình ảnh trên trang 
• Group/Ungroup: nhóm/tách rời các hình được chọn thành  



• Rotate: xoay hoặc lật hình ảnh đã chọn 
❺ Size:  

• Crop: cắt xén ảnh để loại bỏ những vùng không mong muốn 
• Height/ Width: điều chỉnh độ cao/độ rộng của ảnh 

2.4.3. Edraw Max 

Edraw Max là phần mềm giúp thiết kế các hình ảnh đồ họa. Ưu điểm lớn nhất của Edraw Max là thư viện 

sẵn có rộng lớn, với các hình vẽ, các bản mẫu được phân loại theo các chủ đề, giúp người dùng thiết kế 

được các hình ảnh như: sơ đồ tư duy, sơ đồ tổ chức, hình vẽ thí nghiệm, thiết kế poster, mẫu phiếu, tranh 
minh họa… Ngoài ra, Edraw Max cũng hỗ trợ lưu file dưới định dạng bài trình chiếu PowerPoint (*.pptx).  

a. Tạo một file (project) mới 

Trong Edraw Max, mỗi file project (dự án) có thể bao gồm một hoặc nhiều trang. Mỗi trang này có thể 
tương ứng với một hình ảnh hoặc một slide trong bài trình chiếu. Để tạo một file mới trong Edraw Max, 

nhấn chọn File > New.  

►  Tạo file từ bản mẫu sẵn có 

Các bản mẫu trong thư viện của Edraw Max được chia theo các chủ đề. Tìm đến chủ đề bạn quan tâm, 

nhấn chọn bản mẫu và chọn Create. Ví dụ khi chọn một bản mẫu trong chủ đề Science (Khoa học): 

 
►   Tạo file trống 

Để tạo một file trống, trong danh sách chủ đề, nhấn chọn dòng đầu tiên Basic Diagram > Blank Drawing > 

Create  

b. Chỉnh sửa file 

Giao diện làm việc của Edraw Max gồm các phần chính như sau (ví dụ đối với file trống): 



 
►   Vùng thư viện 

Là nơi người dùng tìm thấy các hình vẽ có sẵn, được phân chia thành từng chủ đề. Thông thường có 2 cách 

sử dụng thư viện:  

- Nhấn chọn biểu tượng chồng sách để 
mở thư viện. Tại đây các hình ảnh được 
phân chia theo từng nhóm đối tượng 
hoặc từng chủ đề. Ví dụ để thiết kế một 
hình vẽ mô tả một thí nghiệm khoa 
học, chúng ta sử dụng thư viện hình 
ảnh tại ngăn sau đây: Library > 
Science > Laboratory Equipment. 

- Khi tìm kiếm một hình cụ thể, nhập từ khóa tiếng anh tương ứng vào ô tìm kiếm. 

► Vùng thiết kế 

Là nơi hiển thị các hình ảnh đang trong quá trình chỉnh sửa. Để sử dụng một 
hình ảnh từ thư viện, nhấn chọn hình đó và kéo thả vào vùng thiết kế. Các hình 
ảnh trong thư viện của phần mềm cũng có mức độ tùy chọn khá cao. Ví dụ 
trong hình bên, ta có thể điều chỉnh đóng hoặc mở nắp đèn cồn; điều chỉnh 
hình dáng ngọn lửa; thay đổi độ cao của cồn trong đèn, màu sắc của cồn… 

►   Vùng tùy chỉnh của đối tượng 

Là nơi hiển thị và điều chỉnh các thông số của từng đối tượng như màu nền, màu viền, độ dày viền, kích 
thước, độ nghiêng của hình… 



►   Vùng công cụ 

Là vùng chứa các nhóm lệnh, công cụ và thiết lập cơ bản tương tự như PowerPoint.  

c. Lưu file (project) 

Để lưu trữ file đang chỉnh sửa và có thể tiếp tục chỉnh sửa ở những lần sau, ta cần lưu file dưới dạng project, 
với phần mở rộng là .eddx. Khi mở các file *.eddx này nghĩa là mở ra giao diện làm việc của Edraw Max.  

d. Xuất file (hình ảnh) 

- Để lưu kết quả thiết kế dưới dạng tệp hình ảnh thông thường, nhấn chọn File > Export & Send > 
Graphic > Graphic Format. Cần lưu ý, nếu muốn lưu độ trong suốt của hình ảnh thì cần chọn lưu định 
dạng *.png 

- Sau khi chọn định dạng, tên file và vị trí thư mục lưu trữ, nhấn chọn Save và điều chỉnh các thông số tại 
Export Graphics. Cuối cùng nhấn OK để hoàn tất.  

3. Kỹ năng xây dựng audio tư liệu 

Trong dạy học, giáo viên có thể sử dụng đến các học liệu dạng audio (âm thanh) như băng ghi âm các bài 

hát, đoạn nhạc, câu chuyện, đoạn văn, đoạn hội thoại…  

3.1. Giới thiệu và phân biệt một số định dạng audio 

 *.MP3 *.WMA *.WAV 

Dung lượng 

Dung lượng thấp, dễ dàng chia 
sẻ và lưu trữ 

Dung lượng file thậm chí còn 
nhẹ hơn MP3, dễ dàng chia sẻ 

và lưu trữ 

Dung lượng khá nặng  

Chất lượng 
âm thanh 

Chất lượng âm thanh bị giảm đi 

nhiều so với bản gốc từ phòng 
thu hoặc trong CD 

Chất lượng âm thanh bị giảm đi 

nhiều so với bản gốc từ phòng 
thu hoặc trong CD  

Chất lượng âm thanh không 

hề thua kém âm thanh phòng 
thu  

Về mặt sử dụng, tùy vào nhu cầu mà người dùng có thể lựa chọn định dạng audio phù hợp. Hiện nay, định 
dạng audio được sử dụng rộng rãi nhất là MP3. Do đó việc tìm kiếm và tải các file MP3 miễn phí từ Internet 

cũng tương đối dễ dàng. 

3.2. Ghi âm/Thu âm 

3.2.1. Ghi âm bằng điện thoại di động  

Hầu như tất cả các máy điện thoại hiện nay đều có chức năng ghi âm. Tuy nhiên chất lượng ghi âm của 

điện thoại di động khó có thể so sánh được với các thiết bị ghi âm chuyên dùng. Sau đây là một số chú ý 

giúp cải thiện chất lượng âm thanh khi thực hiện ghi âm bằng điện thoại:  

a. Ghi âm 

- Triệt tiêu các tác nhân gây ồn và gây méo tiếng 
- Ngắt kết nối điện thoại/internet để việc ghi âm không bị gián đoạn bởi cuộc gọi, tin nhắn, thông báo…  
- Điều chỉnh micro ở vị trí phù hợp so với nguồn âm để tránh âm thanh quá to/ quá nhỏ.  



- Cố định vị trí của điện thoại để tránh âm thanh lúc to lúc nhỏ, không đồng nhất. 

b. Chia sẻ, lưu trữ file ghi âm từ điện thoại 

- Để chuyển các file ghi âm này từ điện thoại sang máy tính, bạn cần sử dụng các thết bị kết nối.  
- Trong trường hợp không sử dụng được các thiết bị kết nối giữa điện thoại và máy vi tính, hãy tận dụng 

tối đa các ứng dụng lưu trữ trực tuyến hoặc chia sẻ file trên điện thoại để gửi file ghi âm đó đi. Sau đó 
sử dụng máy vi tính để tải file đã gửi về.  

3.2.2. Ghi âm bằng máy tính 

Ngoài cách sử dụng điện thoại, bạn cũng có thể ghi âm với ứng dụng có sẵn trên máy tính.  

a. Đối với máy tính sử dụng Windows 7, Windows 8 

Công cụ ghi âm có sẵn trên máy tính với hệ điều hành Windows 7, Windows 8 là Sound Recorder. 

❶ Mở Sound Recorder 

- Đối với Windows 7, nhấn chọn Start và nhập từ khóa Sound Recorder vào ô tìm kiếm sẽ thấy xuất 
hiện Sound Recorder (biểu tượng micro). Nhấn chọn vào biểu tượng của phần mềm để mở.   

- Đối với Windows 8, di chuột vào cạnh bên phải màn hình để mở Menu Charms, nhấn vào biểu tượng 
kính lúp và nhập từ khóa Sound Recorder. Nhấn chọn vào biểu tượng của phần mềm để mở.  

❷ Nhấn chọn Start Recording để ghi âm. Thời gian ghi âm sẽ hiển thị trên thanh ghi âm để bạn biết được 
độ dài của đoạn ghi âm. 

 ❸ Khi đã ghi âm xong, nhấn chọn nút Stop Recording để dừng ghi âm. Ngay lập tưc, cửa sổ Save as sẽ 

xuất hiện. Chọn thư mục mà bạn muốn lưu file ghi âm và nhấn Save. Các file ghi âm thu được có định dạng 
là WMA. 

b. Đối với máy tính sử dụng Windows 10 

Sang đến phiên bản Windows 10, công cụ ghi âm trên 
được đổi tên thành Voice Recorder. 

❶ Mở Voice Recorder 

Nhấn chọn biểu tượng Windows (cửa sổ) ở góc dưới bên 

trái màn hình máy tính, bạn sẽ quan sát thấy danh sách các 

phần mềm và ứng dụng trên máy của mình. Kéo xuống phía 

dưới và chọn Voice Recorder.  

❷ Nhấn chọn vào biểu tượng Micro để bắt đầu ghi âm. Khi đó thời gian ghi âm bắt đầu chạy.  

❸ Các nút tạm dừng/dừng ghi âm được hiển thị như hình bên. Ngoài ra Windows 10 còn cung cấp tính 

năng đánh dấu điểm trong đoạn ghi âm, giúp bạn đánh dấu các mốc quan trọng. Mỗi đánh dấu sẽ được 

gắn với một thời gian cụ thể trong đoạn ghi âm.  



❹ Ngay sau khi dừng ghi âm, 

danh sách các file ghi âm sẽ xuất 

hiện kèm ngày, giờ ghi âm và 
thời lượng đoạn ghi âm cụ thể. 

Phía bên phải là nội dung của 

đoạn ghi âm.  

Trong trường hợp đoạn ghi âm 

có các điểm đánh dấu, bạn chỉ 

cần nhấn chọn vào điểm đánh 
dấu thì đoạn phát sẽ chuyển đến 

mốc thời gian đó. Các nút chức 

năng phía bên dưới lần lượt là: 

(1) Share: Chia sẻ file ghi âm  

(2) Trim: Cắt đoạn ghi âm  

(3) Delete: Xóa file ghi âm 

(4) Rename: Đổi tên file ghi âm 



Để tìm đến thư mục chứa các file ghi âm, nhấn chuột phải vào tên file trong danh sách các file 
và chọn Open file location. 

c. Đối với máy Macbook (MacOS) 

Công cụ ghi âm có sẵn trên các máy Macbook là QuickTime Player.  

❶ Để mở QuickTime Player, vào Finder > Applications > File > New Audio Recording 

❷ Lúc này xuất hiện ô Screen Recording. Nhấn chọn 

vào nút tròn màu đỏ ở chính giữa để bắt đầu ghi âm. 

Trong trường hợp xuất hiện thông báo “QickTime 

Player would like to acess the microphone”, nhấn 

chọn OK.  

❸ Sau khi ghi âm xong, nhấn chọn nút vuông (Stop) 
để dừng ghi âm. Sau đó nhấn chọn File > Save as, lựa chọn thư mục muốn lưu file ghi âm và nhấn 

Save.  

3.3. Tải audio từ Internet 

Tùy vào nội dung cần tìm kiếm, người dùng có thể tải file audio từ các trang web chia sẻ nhạc 
miễn phí.  

3.3.1. Một số loại âm thanh thường dùng khi xây dựng audio tư liệu 

a. Các hiệu ứng âm thanh (Sound Effect) 

- Trong quá trình dựng các đoạn ghi âm, video… bạn cần sử dụng đến các âm thanh minh họa. 
Tất cả các âm thanh giúp người nghe liên tưởng đến một đối tượng cụ thể như tiếng nổ, tiếng 
động vật, tiếng xe cộ, tiếng gió, mưa, tiếng chuông điện thoại, tiếng bàn phím… được gọi 
chung là các hiệu ứng âm thanh.  

- Để tìm kiếm các hiệu ứng âm thanh, ngoài cách sử dụng từ khóa tiếng Việt, bạn có thể sử dụng 
từ khóa “Sound Effect” để cho ra các kết quả phong phú hơn. Ví dụ khi tìm kiếm với từ khóa 
“Rooster Sound Effect” hoặc “Morning Rooster Sound Effect” sẽ cho ra kết quả là tiếng gà 
gáy sáng.  

b. Các loại nhạc nền (Background Music hay BGM) 

- Nhạc nền là các bản nhạc được dùng để tạo không khí (vui vẻ, sôi động, buồn, hào hùng… ), 
thường có kết cấu khá đơn giản và không gây quá nhiều sự chú ý của người nghe.  

- Để tìm kiếm nhạc nền, ngoài cách sử dụng từ khóa tiếng Việt, bạn có thể sử dụng từ khóa 
“Background Music” hoặc “BGM”. Ví dụ khi tìm kiếm với từ khóa “Happy BGM” sẽ cho ra 
kết quả là các bài nhạc nền với giai điệu vui tươi.  



3.3.2. Một số trang web chia sẻ audio miễn phí 

a. Youtube Audio Library (Thư viện âm thanh của Youtube)  
- Đăng nhập vào Youtube Studio: studio.youtube.com 
- Lựa chọn Thư viện âm thanh trong menu bên tay trái  

b. Facebook Sound Collection (Bộ sưu tập âm thanh của Facebook)  
- Tìm kiếm với từ khóa “Facebook Sound Collection”  
- Hoặc truy cập địa chỉ www.facebook.com/sound/collection/  

3.4. Sử dụng phần mềm thu âm và chỉnh sửa âm thanh Audacity 

3.4.1. Giới thiệu 

Audacity là phần mềm thu âm và chỉnh sửa âm thanh hoàn toàn miễn phí, đa nền tảng trên 

máy tính và rất dễ sử dụng. Nó cho phép người dùng thu âm, biên tập, chỉnh sửa file âm thanh 
một cách đơn giản và nhanh chóng.  

3.4.2. Hướng dẫn sử dụng Audacity 

a. Tổng quan 

Giao diện làm việc của Audacity như sau:  

 

b. Thu âm 

Trên giao diện làm việc 
của Audacity, ngay 

phía dưới thanh công 

cụ chính là các nút 
phục vụ cho quá trình thu âm.  

c. Biên tập, chỉnh sửa và cắt ghép 

❶ Mở tệp tin 



Để mở một tệp âm thanh trong trình làm việc của Audacity, chọn Menu > File > Open (hoặc 
nhấn tổ hợp phím Ctrl + O) và tím đến tệp âm thanh cần xử lí. Sau khi nạp xong, tệp âm thanh 

sẽ có dạng 2 biểu đồ song âm song song, với phía trên là kênh trái và phía dưới là kênh phải:  

 
Ngoài ra, bạn cũng có thể mở tệp âm thanh bằng cách kéo trực tiếp tệp âm thanh từ máy tính và 

thả vào vùng làm việc của Audacity.  

❷ Cắt bỏ một đoạn âm thanh 

Nhấn chuột vào vùng sóng âm để chọn thời điểm bắt đầu đoạn cần xóa. Tiếp theo nhấn giữ chuột 
và rê về phía bên phải để lựa chọn điểm kết thúc (mốc thời gian bắt đầu và kết thúc của đoạn âm 
thanh đã lựa chọn sẽ được hiển thị ở thanh trạng thái). 

 
Nhấn chuột vào biểu tượng cây kéo (hoặc nhấn nút Delete, Ctrl + X) để xóa đoạn âm thanh đã 
chọn. 
❸ Tách một đoạn âm thanh ra tệp mới 
- Cách 1: Nhấn chuột vào cùng sóng âm để chọn thời điểm bắt đầu đoạn cần tách. Sau đó nhấn 

chọn Menu > File > Export > Export Selected Audio…  
- Cách 2: Nhấn chuột vào vùng sống âm để chọn thời điểm bắt đầu đoạn cần tách. Nhấn tổ hợp 

phím Ctrl + C  để sao chép đoạn vừa chọn. Mở một cửa sổ Audacity mới bằng cách nhấn 
chọn Menu > File > New hoặc nhấn tổ hợp phím Ctrl + N. Trên cửa sổ mới vừa mở, nhấn tổ 
hợp phím Ctrl + V để dán đoạn đã cắt vào tệp mới này. Sau đó nhấn chọn Menu > File > 
Export > Export As… để lưu lại tệp tin này.  



❹ Ghép nhiều tệp âm thanh: Khi thực hiện ghép nhiều file, người dùng có thể ghép nối (nghĩa 
là file sau nối liền với file trước) hoặc ghép song song (âm thanh chồng lên nhau).  

- Ghép song song: Mở file thứ nhất trong Audacity. Sau đó nhấn chọn File > Import > Audio, 
tìm đến thư mục chứa các file cần ghép và chọn file (một hoặc nhiều file) muốn ghép, sau đó 
nhấn chọn Open.  

- Ghép nối tiếp: Mở mỗi file cần ghép trong một cửa sổ làm việc của Audacity. Dựa theo thứ tự 
ghép nối, mở cửa sổ chứa file thứ hai, nhấn tổ hợp phím Ctrl + A để chọn cả file, sau đó nhấn 
Ctrl + C để sao chép file. Tiếp tục mở của sổ chứa file thứ nhất, đặt con trỏ chuột tại vị trí kết 
thúc vùng sóng âm của file thứ nhất rồi nhấn tổ hợp phím Ctrl + V để dán file thứ hai vào. 
Thực hiện tương tự với các file thứ 3, thứ 4… 

d. Các hiệu ứng (Effect) của Audacity 

Tại giao diện làm việc của Audacity, nhấn chọn đoạn âm thanh muốn áp dụng hiệu ứng, sau đó 
nhấn chọn Effect (trên thanh công cụ) để xem các hiệu ứng. Tại đây có 35 bộ lọc và hiệu ứng đặc 
biệt để áp dụng cho các bản nhạc. Khi chọn một hiệu ứng bất kì, đều có sẵn các nút 
Preview/Playback để bạn có thể duyệt qua đoạn âm thanh vừa được hiệu chỉnh trước khi bấm 
Apply/OK để áp dụng hiệu ứng.  
Một số hiệu ứng thường dùng: 

❶ Lọc bỏ tạp âm (Noise Reduction) 

- Mở tệp âm thanh cần xử lí, sau đó chọn vùng âm thanh cần lọc bỏ tạp âm.  
- Nhấn chọn Menu > Effect > Noise Reduction… 
- Nhấn chọn Get Noise 

Profile để phần mềm tiến 
hành lấy mẫu của đoạn âm 
thanh có chứa tạp âm. Lúc 
này cửa sổ của hiệu ứng sẽ 
biến mất và trở về giao diện 
chính của Audacity. Bấm 
chọn khoảng có nhiều tiếng 
ồn trong tệp âm thanh của 
bạn. Sau đó mở lại bảng điều 
khiển hiệu ứng bằng cách 
nhấn chọn Menu > Effect > 
Noise Reduction… 



- Điều chỉnh các thông số và bấm Preview để nghe thử âm thanh sau khi lọc. Cần chú ý thông 
số Noise Reduction, chỉ số này càng lớn thì tiếng ồn càng giảm, nhưng đồng thời chất lượng 
âm thanh cũng sẽ giảm.  

- Sau khi điều chỉnh các thông số phù hợp, nhấn OK để phần mềm tiến hành loại bỏ tiếng ồn.  

❷ Điều chỉnh âm lượng của tệp tin hoặc đoạn âm thanh 

- Chọn vùng âm thanh cần điều chỉnh âm lượng, sau đó nhấn chọn Effect > Amplify 
- Dùng chuột điều chỉnh thanh trượt về bên phải để tăng âm lượng và bên trái để giảm âm lượng. 

Nhấn Preview để nghe thử. 
- Sau khi điều chỉnh âm lượng xong, đánh dấu vào ô Allow clipping rồi nhấn nút OK để hoàn 

tất.  

❸ Điều chỉnh tốc độ âm thanh 

- Chọn đoạn âm thanh cần điều chỉnh, sau đó nhấn chuột chọn Effect > Change Speed. 
- Dùng chuột điều chỉnh thanh trượt về bên phải để tăng và bên trái để giảm tốc độ âm thanh. 

Nhấn Preview để nghe thử.  
- Sau khi điều chỉnh tốc độ xong, nhấn nút OK để hoàn tất.  

4. Kỹ năng xây dựng video clip tư liệu  

4.1. Giới thiệu và phân biệt một số định dạng video phổ biến 

 *.AVI *.FLV *.MP4 *.WMV 

Dung lượng file Lớn Nhỏ Nhỏ Nhỏ nhất 

Chất lượng hình ảnh Cao  Tốt Tốt Trung bình 

Chất lượng âm thanh Cao Tốt  Tốt Trung bình 

Hỗ trợ streaming Không Có  Có Có 

Tích hợp 
Xem được trên 
hầu hết thiết bị 

Cần cài thêm 
codec 

Xem được trên 
hầu hết thiết bị 

Cần cài phần mềm 
trên Macbook 

Sử dụng Lưu trữ, Web Web Web,  lưu trữ Chia sẻ qua email 

4.2. Quay video 

4.2.1. Quay video bằng điện thoại di động hoặc máy quay (máy ghi hình) 

Tính năng quay video cũng có trên hầu hết các điện thoại di động thông minh hiện nay, tuy nhiên 
chất lượng video còn phụ thuộc vào dòng máy. Trong trường hợp yêu cầu chất lượng video tương 



đối tốt, bạn cần sử dụng các điện thoại có camera chất lượng cao hoặc sử dụng các máy quay, 
máy ghi hình chuyên dùng. 

Về kĩ thuật, tương tự như khi chụp ảnh, người quay video cần chú ý:  

- Giữ mặt kính (máy quay) hoặc camera (điện thoại) sạch và không bám bụi. 
- Sử dụng đế giữ điện thoại hoặc chân máy để tránh rung lắc 
- Hạn chế sử dụng tính năng zoom tự động vì tính năng này làm giảm độ sắc nét của hình. Thay 

vì zoom, nên điều chỉnh khoảng cách giữa máy và đối tượng cần quay. 
- Đảm bảo video quay đủ sáng 
- Trong trường hợp cần thu tiếng, nên để máy gần với nguồn âm hoặc sử dụng thêm micro hỗ 

trợ thu âm. 
- Nên chọn chế độ quay với màn hình ngang 

4.2.2. Quay video màn hình máy tính 

Trong một số trường hợp, chúng ta cần ghi lại các thao tác trên màn hình máy tính bằng cách 
quay video. Sau đây là 2 cách ghi hình với màn hình máy tính: 

a. Quay video màn hình máy tính bằng PowerPoint 

Quay video màn hình máy tính là tính năng mới, được cung cấp ở các 
phiên bản từ Office 2013 trở về sau.  

❶ Để bắt đầu ghi hình, nhấn chọn tab Insert, trong nhóm công cụ 
Media, nhấn chọn Screen Recording. 

❷ Lúc này bảng điều khiển của Screen Recording hiện lên.  

Nhấn chọn 
Select Area, khi 
đó màn hình tối 
đi và con trỏ 
chuột trở thành 
hình dấu +. Đặt 
con trỏ chuột và 
kéo để chọn 
phạm vi muốn 
ghi hình., phần 
được chọn sẽ 
được giới hạn 
trong một khung 



chữ nhật có viền nét đứt màu đỏ. Nếu muốn điều chỉnh lại phạm vi, nhấn chọn Slect Area một lần 
nữa.  

Trong trường hợp phần màn hình đang hiển thị không phải cửa sổ bạn muốn ghi hình, cứ tiếp tục 
chọn phạm vi vì sau khi bấm ghi hình bạn vẫn có thể mở sang các cửa sổ khác. 

❸ Trên bảng điều khiển, 2 tính năng Audio (ghi âm thanh) và Record Pointer (ghi con trỏ chuột) 
đang được lựa chọn theo mặc định. Bạn có thể tắt bằng cách nhấn chọn tính năng đó.  

❹ Khi đã hoàn thành thiết lập, nhấn chọn nút tròn màu đỏ (Record) để bắt đầu ghi hình.  

❺ Sau khi ghi hình xong, nhấn tổ hợp phím Windows + Shift + Q để ngừng ghi hình. Lúc này 
video vừa quay được chèn luôn trong slide hiện tại của PowerPoint. Để thêm hiệu ứng hoặc cắt 
sửa video, nhấn chuột phải chọn vào video và chọn Style (phong cách) hoặc Trim (cắt sửa). Để 
lưu thành tệp video, tiếp tục nhấn chuột phải vào video và chọn Save Media as…. 

b. Quay video màn hình bằng Bandicam 

Bandicam là ứng dụng quay video màn hình và 
chụp webcam tương đối quen thuộc đối với 

người dùng Internet.  

- Ưu điểm: Giao diện dễ sử dụng; nhiều chế độ quay và hiệu ứng cho chuột; hỗ trợ ngôn ngữ 
Tiếng Việt, chất lượng rõ nét, ngăn tạp âm tối đa, hỗ trợ ghi chú, tạo hình vẽ cho video 

- Nhược điểm: video bị giới hạn độ dài 10 phút và bị gắn watermark ở bản miễn phí; không thể 
chỉnh sửa trực tiếp video đã quay mà phải sử dụng phần mềm Bandicut; một số video sau khi 
xuất bị giật khi xem 

Để quay màn hình với phần mềm này, chúng ta thực hiện như sau:  

❶ Trước khi quay video màn hình, ta cần thực hiện một số thiết lập: 

- Nhấn chọn tab Tổng quát: chọn thư mục lưu video sau khi quay  
- Nhấn chọn tab Video: thiết lập các hiệu ứng, định dạng video và phím tắt quay/dừng video 
- Nhấn chuột vào dấu mũi tên bên trái màn hình  để chọn vùng quay trên màn hình.  

 

❷ Khi đã chọn phạm vi khung hình, nhấn chọn REC ở phía bên phải để bắt đầu ghi hình. 



 

❸ Ngay khi quá trình ghi hình bắt đầu, bạn có thể thu gọn bảng điều khiển xuống để không làm 
cản trở quá trình ghi hình.  

 
❹ Để dừng ghi hình, nhấn chọn nút REC hoặc có thể nhấn biểu tượng ô vuông màu đỏ. 

❺ Sau khi hoàn tất việc ghi hình, video quay màn hình của bạn được tự động lưu ở thư mục đã 
thiết lập ở bước 1.  

4.3. Biên tập video 

4.3.1. Sử dụng VivaVideo 

a. Tổng quan về VivaVideo 

VivaVideo là ứng dụng di động dùng để biên tập, chỉnh sửa video chuyên nghiệp 

với giao diện đơn giản, tiện dụng. 

- Ưu điểm: chỉnh sửa, cắt, gộp video dễ dàng; là ứng dụng di động (Android, 
IOS) nên thuận tiện cho việc chỉnh sửa video ở mọi nơi; có nhiều hiệu ứng 
đẹp, chuyên nghiệp 

- Nhược điểm: phải trả phí duy trì hàng tháng để sử dụng được đầy đủ các tính năng; khi sử dụng 
bản miễn phí: chất lượng video thấp (tối đa 480p), bị giới hạn thời gian (tối đa 5 phút) và bị 
gắn watermark. 

b. Cài đặt 

Để cài đặt VivaVideo, bạn cần tìm kiếm ứng dụng này trong kho ứng dụng trên thiết bị của 

mình (Google Play đối với Android và AppStore đối với IOS) và tiến hành cài đặt.  



c. Sử dụng VivaVideo 

► Màn hình chính 

Giao diện của VivaVideo khá đơn giản với 3 nút 
sử dụng chính: 
- Edit: Chỉnh sửa video 
- My drafts: Các bản nháp của video, 

slideshow đang chỉnh sửa 
- Slideshow: Tạo video từ ảnh 

► Giao diện chỉnh sửa cơ bản 

Khi tiến hành chỉnh sửa một video hoặc slideshow bất kì, giao 

diện chỉnh sửa của VivaVideo có dạng như hình bên, trong đó:  

- Thanh công cụ: X (đóng), Undo, Redo, Draft, Save 
- Xem thử video 
- Nhóm công cụ:  

• Theme: cho phép chọn từ danh sách các mẫu video với 
nhiều chủ đề có sẵn 

• Music: cho phép xóa âm thanh của video, chọn nhạc nền 
hoặc hiệu ứng âm thanh từ thư viện trực tuyến, ghi âm 
trực tiếp. 

• Clip Edit: Cho phép chỉnh sửa khung hình, crop video, 
tăng giảm tốc độ, âm lượng của video 

• Text & Fx: cho phép thêm, chỉnh sửa văn bản, hình ảnh, 
màu sắc vào video 

• Filter: bộ lọc màu video với nhiều chủ đề 

► Tạo Slideshow/ Chỉnh sửa video 

- Tại giao diện chính của phần mềm, nhấn chọn 
Slideshow/Edit để tạo slideshow hoặc chỉnh sửa video.  

- Khi cửa sổ chọn ảnh hiện ra, nhấn chọn các ảnh/video và nhấn Next 
- Thêm các đoạn mô tả, âm thanh, hiệu ứng, bộ lọc… vào slideshow/video của bạn 
- Khi hoàn thiện, nhấn chọn Save và chọn chất lượng video muốn lưu 

Lưu ý: Nếu chưa sửa xong slideshow, nhấn chọn Draft để lưu bản nháp.  



4.3.2. Sử dụng VSDC Video Editor 

a. Tổng quan về VSDC Video Editor 

VSDC Video Editor là phần mềm cho phép bạn quay lại màn hình, chỉnh sửa video như thêm phụ 

đề, lọc âm thanh, thêm hiệu ứng nhanh chóng. Bên cạnh đó giao diện của phần mềm đơn giản, 

tiện dụng và nhiều tính năng hơn so với các phần mềm miễn phí khác.  

Sau khi khởi động phần mềm, 
ta có các tùy chọn nhanh như 
sau:  
- Tạo một dự án mới 
- Tạo dự án slideshow từ ảnh 
- Import nội dung đa phương 

tiện 
- Ghi hình từ webcam hoặc 

thiết bị ghi hình khác 
- Quay phim màn hình 

b. Biên tập video với VSDC Video Editor  

❶ Nhấn chọn Blank Project để tạo một dự án mới. Tại đây, ta điền các thông tin về dự án 
(Project title – tên dự án, Resolution – độ phân giải của video xuất ra) và nhấn Finish. 

❷ Giao diện làm việc của phần mềm gồm các vùng chính như sau:  

 



► Vùng màu đỏ: Timeline. Những phần nội dung bạn thêm vào sẽ được hiển thị trên Timeline 
và thứ tự xuất hiện cũng như thời gian xuất hiện trên video của những nội dung đó, bạn cũng có 

thể theo dõi và điều chỉnh trực tiếp trên Timeline. Để bắt đầu chỉnh sửa, kéo thả tệp vào Timeline.  

► Vùng màu xanh dương: nơi hiển thị nội dung của video (theo vị trí của con trỏ chuột) 

► Vùng màu xanh lá: Object Tools, cho phép bạn thêm vào những nội dung như video, nhạc, 

text… 

► Vùng màu vàng: dùng để xác định vị trí con trỏ chuột cũng như giới hạn khu vực làm việc của 

bạn. 

c. Xuất video 

Để xuất video, ta lựa chọn và thay đổi các tùy chọn tại tab Export project: 

 

4.4. Lưu trữ và chia sẻ video 

Khác với các tệp hình ảnh và audio, các tệp video thường có kích thước tương đối lớn, từ vài chục 

MB đến vài GB tùy thuộc chất lượng và độ dài của video. Do đó, để dễ dàng lưu trữ và chia sẻ 

chúng, ta thường sử dụng các nền tảng chia sẻ video. Trong đó phổ biến nhất là Youtube, tại địa 
chỉ https://www.youtube.com.  

4.4.1. Tải video lên Youtube 

❶ Đăng nhập vào Youtube Studio 

❷ Ở góc trên cùng bên phải màn hình, nhấp vào biểu tượng máy quay Tạo > Tải video lên 

❸ Tìm đến thư mục lưu trữ và chọn tệp video mà bạn muốn tải lên.  

❹ Thêm các thông tin cơ bản như tiêu đề, nội dung mô tả… cho video của bạn.  

❺ Tùy chọn các cài đặt nâng cao như thẻ từ khóa, ngôn ngữ và phụ đề, bật/tắt bình luận … 

(nếu cần). 

❻ Xem trước và xuất bản video.  



4.4.2. Chia sẻ video  
Để chia sẻ một video bất kì trên Youtube, nhấn chọn Chia sẻ ở phía dưới video đó. Cách chia sẻ 

thông dụng nhất là sử dụng đường link của video: Nhấn chọn Copy để sao chép đường link của 

video; sau đó dán (Paste) đường link này và  gửi cho người bạn muốn chia sẻ.  

 
Ngoài ra, bạn cũng có thể chia sẻ với tùy chọn video sẽ bắt đầu phát ở thời gian nhất định bằng 

cách tích chọn ô Start at và nhập thời điểm bắt đầu. 

 


